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1   Introduction
T-Link Console Software is a stand-alone application that provides remote and local support for the configuration of T-
Link TL3xx, T-Link TL2xx devices and IP Receiver line cards. T-Link Console generates and deploys unique encryption
keys and protocols  for communication between T-Link Console, T-Link TL3xx and T-Link TL2xx. T-Link Console
software functions in three operational modes; Operator Mode, Unattended Mode and Database Absent Mode. 

A summary of  T-Link Console Software features are listed below:

• Stand-alone application
• High level encryption
• User Management
• Software upgrades via network
• Advanced T-Link accounts search and management
• Local and remote programming of the T-Link TL2xx options
• Integration with DRL3-IP
• Management of the IP Receiver’s T-Link Tables
• Different operational modes including Unattended Mode
• Database backup/restore
• Database repair/compact 
• Windows NT/2000/XP/2003 compatible
• Multiple database support

1.1   System Requirements
The minimum and recommended system requirements are indicated below.

Minimum System Requirements
• IBM-compatible PC
• CD-ROM drive
• T-Link Console Installation CD
• *Windows® XP, Windows® 2000 or Windows® NT v4.0 with Service Pack 4

• *350 MHz Intel® Pentium II Processor with 64 MB of RAM, minimum of 5 MB of free disk space (excluding 
database)

• SVGA monitor, mouse, keyboard
• Windows-compatible sound card
• A video card and monitor configured to display 800 x 600 pixels in 16 Bit High Color.

Recommended System Requirements
• IBM-compatible PC
• CD-ROM drive
• T-Link Console Installation CD
• *Windows® NT v4.0 with Service Pack 6, Windows® XP, Windows® 2000

• *500 MHz Intel® Pentium III Processor with 128 MB of RAM and a minimum of 5 GB of free disk space
• SVGA monitor, mouse, keyboard
• Windows-compatible sound card
• A video card and monitor configured to display 1024 x 768 pixels in 16 Bit True Color. This will provide more 

viewing space for the message windows.

New to Version 1.20
• Choice of creating accounts for V1.0X, V1.1x and V1.2x T-Link accounts.
• T-Link TL300 Options supported
• Ability to save open account in Remote Programming as a template.
• Only Administrator users can view the DRL3-IP Receiver Table

NOTE: The T-Link Console v1.20 is required to configure T-Link TL300 V1.20 and higher.

NOTE: T-Link accounts can not be downgraded in the T-Link database, the account must be deleted and re-added if this 
is required.

* Microsoft® and  Windows® 2000 Professional are registered trademarks of Microsoft Corporation in the United States and/or other countries. 
Intel® and Pentium® are registered trademarks of the Intel corporation.
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1.2   Initial Login
The Operator mode is subdivided into three access levels including; Supervisor, Administrator and User modes. 
The initial login after software installation must performed in Supervisor or Administrator mode. This allows the 
Supervisor or Administrator to assign initial passwords and access levels to users. 

Note: Only the Supervisor can create additional Administrators.

To login initially as a Supervisor, enter "supervisor" in the Login Name field and "password" in the Password 
field. The default password is "password". DSC recommends that you change Supervisor password immediately after 
the first login. 

Note: Login name and password fields are case-sensitive.

Note: There is only one supervisor login and password. Ensure that you do not lose this password.

Refer to Section 2.2 for Login/Logout, Refer to Section 5.2 for Change Passwords and Refer to Section 1.3 for details on 
User Levels.

1.3   Operating Modes
T- Link Console software functions in three operational modes; Operator Mode, Unattended Mode and Database 
Absent Mode. 

Operator Mode - Operator mode comprises 3 modes including Supervisor, Administrator and User.  Each Operator mode has 
different access to the 5 applications as indicated below:

Unattended Mode - Unattended Mode allows all users to view current logs only. This mode automatically occurs after a pro-
grammed auto-logout time occurs. This mode prevents accidental closing of the T-Link Console. 

Database Absent Mode - This mode allows any user to restore a previously saved backup database if the database is absent. 
This mode also provides access to Compact and Repair functions. 

T-Link Console Functions Supervisor Administrator User

T-Link Accounts Add Accounts
Edit Accounts
Delete Accounts
T-Link Template
Local Programming
Remote Programming
Update Receivers
Import Accounts
Export Accounts

�
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�
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�
�

�

�
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IP Receivers Add Receivers
Edit Receivers
Delete Receivers
Receiver T-Link Table

�
�

�

�

�
�

�

�

�
�

�

�

User Management Add User
Edit User
Delete User
Change Password
View Encryption Keys

�
�

�

�
�

�
�

�

�
�

�
�

�

�
�

Logs Delete Log Entry
Delete All Logs
Export To Excel

View 
Logs
Only

�

�

�

View 
Logs
Only

Configuration Access Settings � � �
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2   General Features
2.1   Navigating T-Link Console Software.

The main form is divided up into several functional areas. Multiple ways are available for accessing most features. All 
features can be accessed by selection form the Menu Bar , Tool Bar, Application Tab or from the Left Side Bar.

The Information Bar located on the right side of the screen  provides additional information regarding an account 
depending on which application is being accessed.

The Status Bar located at the bottom of the screen indicates the current operating mode, Logon ID and time, and the local 
IP address.

There are 5 main sections of the application the user may have access to, depending on their user type.

• T-Link Accounts
• IP Receivers
• User Management
• Logs
• Configuration
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2.2   Login/Logout

The Login screen is automatically displayed when the system first boots up.
If you are not logged into the T-Link Console use this function to login as an authorized user. Use this function to log out 
of the T-Link Console. 

Login/Logout can be accessed by: 
Clicking on the Log out/ Login in Icon on the tool bar (left) or...
Selecting File > Log in or File > Log out from the menu bar.

When logged out, you will not be able to make any in changes T-Link Console.

T-Link Console software supports three user levels: Supervisor, Administrator and User.

Supervisor Login
The supervisor access level is restricted to the editing of Administrator level users and User level users. The supervisor 
is the only user who can add an Administrator level user. There is only one supervisor login and password. Care must be 
taken not to lose this password. After logging in as supervisor, reduced version of T-Link console will be displayed. The 
supervisor has no access to T-Link accounts, or logs, but only user data. The supervisor will not be requested to load a 
T-Link Database on login. 

Admin Login
The administrator access level has access to all features of the software, except for the editing of the supervisor login, or 
other administrator logins. The administrator has full access to T-Link accounts. The administrator can add other User 
level users, change their own password, but cannot modify other Administrator level users. The administrator is the only 
user that can configure the T-Link console. 

User Login
The User access level has access to all T-Link software. Users can create, modify and delete T-Link accounts. The user 
access level can only change their own password, and cannot modify any other users. 

Note: You must log in as Admin or Supervisor for first time login after installation.

To login in as a Supervisor, type in "supervisor" in the Login Name field and your password in the Password field.
The default password is "password".

To login in as an Administrator, enter "admin" in the Login Name field and your password in the Password field.
The default password is "password"

To log in as a User, enter your login name in the Login Name field and the password provided to you in Password field 
in the following screen. Click OK.

Note: Login name and password fields are case-sensitive.
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Note: You may be notified that you need to change your password on this screen.

Enter your new password and then re-enter the password to confirm it as indicated below.  Click  OK to approve the new 
password.

Note: The password must be at least 8 characters long. 

If the password entered is valid the following screen will be displayed:

 After entering your login name and password you will be prompted to enter a T-Link Database if you logged in as an 
Admin or User access level. Select the T-Link account you require and click on Open.
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The T-Link Console main screen will be displayed.

2.3   Configure T-Link Console
Configure T-Link Console is only available to the Administrator. To access the configuration screen:

Configure T-Link Console can be accessed by: 
Clicking on the Configure  Icon on the tool bar (left) or...
Selecting Tools > Configure from the menu bar.

Access Settings

Selecting the access tab  allows the user to enable, disable and edit (days before expiry) password expiry;  and enable, 
disable and edit the Auto-logout timer (inactivity in minutes).
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2.4   About
The About menu provides version identification and contact information for Sur-Gard products.

T-Link Console About can be accessed by: 
Clicking on the About Icon on the tool bar (left) or...
Selecting Help > About from the menu bar.

Clicking on the web site address opens the DSC web site in the default Internet browser installed on the computer. 
Similarly, clicking on the e-mail address opens a blank e-mail, using the default email program installed. When finished 
with this screen, click the Done button to return to the previous screen.

2.5   Exit
The Exit icon allows a logged on user to exit from the T-Link Console. Selecting Exit terminates ALL active 
connections.

Exit can be accessed by: 
Clicking on the Exit Icon on the tool bar or...
Selecting File > Exit from the menu bar.

 When the user exits from T-Link Console software, the following dialog will be displayed:

This screen displays the following information: 

•  Version number 
•  Company information
•  Phone and Fax numbers
•  Technical Support email address
•  Web site address
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3   T-Link Accounts
3.1   General

T-Link Accounts are available to User, and Administrator access types. It can be accessed by:

• Clicking on the T-Link Accounts  application tab at the top of the screen
• Clicking on the T-Link Accounts bar on the left side bar, 
• Selecting View > T-Link Accounts from the menu bar.

There are 5 sub sections accessible from here, and they are

• Template programming
• Programming
• Update receivers
• Export T-Link Account
• Import T-Link Account 

Current T-Links accounts that are programmed into the console are displayed in a table. The table shows the T-Link 
Account code, IP Address, and Encryption key for each T-Link in this database. 

The user can Add, Edit, Delete T-Links by either clicking on the corresponding button on the bar at the left, clicking on 
the button at the bottom of the screen, or right-clicking on the actual account. 

The user can access the sub functions by either right clicking on the account, clicking on the corresponding button in the 
side bar, or a button on the top of this screen.
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Template Programming

Template programming allows the user to create a set of options that can be used to create accounts of similar types. 
Template programming is accessible from the T-Link Accounts screen by either clicking on the T-Link Template button 
on the left, the T-Link Template button on the top, or right clicking on the Account table. 

The T-Link Template editor opens with all options set to their default values. The user can edit these options as required. 
All other options from the template will be copied into the T-Link account. 

The user can print the current template or save it to a file for creating and programming T-Link accounts at a later date.

Programming
The user can perform actual programming of the T-Link options here. The user can enter Programming by selecting a T-
Link account, and clicking on the respective button on the top, left, or right click on the account.

Upon entering Programming, a table containing all T-Links options and the locally stored values in the T-Link Console 
are displayed under the heading Option Value. 
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The user can select an option and retrieve its value from the T-Link into Current Value by clicking on Get Option. The 
user can also retrieve the entire option set into Current Value by clicking on Get All Options. Any entries in this table 
where the Current Value does not equal the Option Value will be shown as purple. Any options that are current (the 
same as in the T-Link, Current Value equals Option Value) will be shown as green. 

When the Console initially communicates to the T-Link for either a Remote or Local programming session, a Lead In is 
performed to request the T-Link to perform programming, and if it accepts, it will not accept programming from any 
other T-Link Console until Programming is complete. When programming is complete, the T-Link Console software will 
perform a Lead Out to allow other T-Link Consoles to connect to it. If the user has changed an option that will require a 
reset of the T-Link, the user will be presented with the option to do so.

The Console also provides functionality to update the current option set stored in the Console Option Value with what is 
stored in the T-Link Current Value by importing that option. This may done by selecting the option and clicking on 
Import Value to import just one option, or clicking on Import All Values to copy every options Current Value into 
Option Value.  

To change an option value, the user selects the option to be changed by double clicking on it, clicking on Edit, or right 
clicking on the option. The option editor will be displayed allowing the user to edit the option or set it to the default 
value. 

The user can print the current option set by clicking on Print, or by right-clicking on the option table and selecting Print 
Options. The printout displays the T-Link account code, the database file in where it is stored, and the option set 
containing the Option Number, Option Name, and Option Value. This is the value stored in the T-Link Console’s 
Option Value. 
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Update Receivers

The Update Receiver function allows the user to connect to the receivers programmed in the T-Link Account, and update 
them with the T-Links current IP, Account Number and Encryption Key. This can only be performed on IP Receivers 
that are programmed in the T-Link and in the IP Receiver list. The user can access Update Receivers by selecting the 
required T-Link and then by:

 
• Clicking on Update Receivers tab at the top of the screen or
• Right clicking on the Account or 
• Clicking on Update Receivers on the left side bar. 

User will then click the Update button on the following screen. 
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Export and Import T-Link Account
The Console provides the user with the ability to export and import T-Link account files to transfer them to another 
database, or to another T-Link Console software installation. This is done from the main T-Link Account table. The user 
selects Import or Export by:

Right clicking on the desired account and selecting Import or Export or, 
Selecting Tools >Export (or Import) T-Link Account on the menu bar. 

An exported T-Link account contains the entire option set as well as the public IP of the T-Link. This is the IP that 
appears in the T-Link account window and is the IP used to connect to the T-Link.

3.2    T-Link Programming

T-Link Account
To connect to a T-Link, you must add an account to the T-Link Console. The Account information contains the 
information required to connect to the T-Link from the Console. This includes:

• Account Code
• IP Address
• Encryption Key
• Installer’s Code
• Console Port

The T-Link version also includes the information required to connect the T-Link to the DRL3-IP Receiver

• Receiver Remote Port
• Receiver 1 IP Address
• Receiver 1 Gateway
• Receiver 2 IP Address
• Receiver 2 Gateway
• Receiver 3 IP Address
• Receiver 3 Gateway

To add a T-Link account :
• Click on the T-Link Accounts tab or
• Click on  Add at the bottom of the screen or
• Click on Add on the left side bar or Right click on the table. 
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The user must enter a unique Account code for the current Database, an IP Address of the T-Link they wish to connect 
to, and its Encryption Key, if necessary.  

Note: The IP address entered here is used to connect to the T-Link. 

If this address is to be used through a gateway or on the internet, then the public IP address of the T-Link must be 
entered here, and the correct port forwarding must be enabled on the gateway that the T-Link is behind. See the 
following example.  

In this example, the user would enter the address of  24.1.2.3 in to establish a connection to the T-Link. The user may 
have to enter a static port route on the router to connect to the T-Link. 

After clicking Save, the user is prompted with the option to load a Template set of options. If the user selects T-Link 
Template file, the Template options will be applied to the T-Link Account when programming. If the user selects 
template options, the following options must be entered.

• T-Link IP Address
• T-Link Encryption Key
• T-Link Account Code
• Console Port
• Receiver Remote Port

Programming
Programming is done via TCP-IP. The Console connects to the T-Link IP programmed for the T-Link Account. This can 
be used to connect either remotely or locally through a reversed cable.

This method also allows programming an encryption key if required by the user. An encryption key of all zeroes (0’s), 
disables encryption. The T-Link and the T-Link Console must have the same encryption key for valid communications. 

The Remote/Local programming table displays the current programmed set of Options for the selected T-Link, and the 
current set of options stored in this database. There are 5 headings in this table as follows:

• Option Number - This is the same as the section number of the particular option.
• Name - The option’s name
• Current Value - This is the value that is currently programmed in the T-Link. You must perform a Get All Options

or a Get Option in order to obtain this. (see below)
• Option Value - This is the value currently stored in the Console database for this particular option
• Description - A brief text description of what the option is.

PC running
T-Link Console

Software

WAN IP Address
24.1.2.4

Internet / WAN

T-Link

Local IP Address     192.168.1.100

WAN IP Address     24.1.2.3
Local IP Address     192.168.1.1

Firewall 

Router

Gateway
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The color of each line will either be Purple, or Green. A purple line indicates that the stored database value (Option 
Value) does not match what is programmed in the T-Link (Current Value), or is NOT current (has not been received 
from the T-Link yet). Green indicates that the stored value is current and matches the value in the T-Link.

The following functions exist for Programming

• Get All Options
• Get Option
• Set All Options
• Set Option
• Import Value
• Import All Values
• Edit (current option)
• Print (Option Set)
• Save as Template

These functions are available by either clicking on their corresponding button on the bottom of the screen, or right-
clicking on the table. 

Note: Double-clicking on an option in the table will open up the editor. 

Get All Options
Selecting Get All Options retrieves the entire option set from the T-Link. The Current Value is updated and the color of 
each line of the selected option is changed. 

Get Option
Selecting Get Option retrieves the selected option from the T-Link. The Current Value is updated for the selected 
option.

Set All Options
Selecting Set All Options programs the T-link with all of the option values stored in Option Value. Options affecting 
communications such as Encryption Key, Installers Code are NOT changed. See Changing Encryption Key or Installers 
Code below. 

Set Option
Selecting Set Option programs the current option selected from the T-Link. The T-Link is updated with the value stored 
in Option Value. 

Import Value
Selecting Import Value copies the value retrieved from the T-Link (Current Value) to the database for this Account 
(Option Value). This option updates the database with the value currently programmed in the T-Link.

Import All Values
Selecting Import All Values copies all retrieved values from the T-Link (Current Value) to the database for this Account 
(Option Value). This option updates the entire account with all current values from the T-link. Typically, selecting Get 
All Options, followed by selecting Import All Values,  is used to update the database with the current T-Link.

Edit Option
Selecting Edit Option opens the Option Editor for the selected option. This allows the user to change the values stored in 
the database for that particular account. 
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Changing the Encryption Key

Note: Changing the Encryption Key or changing the Installer’s code value immediately affects the way the T-Link 
Console communicates with the T-Link. Successful communication between the T-Link and the T-Link console software 
requires that the Encryption Key and the Installer’s code in the T-Link matches that in the T-Link Console software.

To change the encryption key, click on either Edit or Set Option when the T-Link Console or T-Link encryption key 
option is selected. This opens the Encryption Key editor. 

The user may edit the new encryption key, and then click on Set the New Key to program it to the T-Link. This updates 
the T-Link  and the T-Link Console with the new encryption key. The new key will be used for all subsequent 
communications.

Note: If the user clicks on Save, only the T-Link Console will be updated with the encryption key. This is 
the same as editing the encryption key from the Account editor. The T-Link and the T-Link Console must have matching 
encryption keys for successful communication. 

Changing Installers Code

After the user changes the Installers code, the user is be prompted to change the option immediately. All subsequent 
communication will use the new Installers code. This must be done to ensure that the T-Link and the T-Link Console 
have matching values and to allow programming. If the user decides not to change the option only the Installers code in 
the Account form will change and communications between the T-Link Console, and the T-Link will be disabled.

Note: Changing the Installer’s code without programming the T-Link will only change it in the T-Link 
Console software. To change the Installer’s code in the T-Link it must be programmed. 
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4   IP Receivers
This section is available to User, and Administrator access types. It can be accessed by:

• Clicking on the IP Receivers  application tab at the top of the screen. 
• Clicking on the IP Receivers bar on the left side bar, 
• Selecting View > IP Receivers on the menu bar.

The IP Receivers currently programmed into the T-Link console are displayed in a table here. The table contains the 
Receiver’s IP address, Receiver Name, and Receiver Type. The User entered Receiver Description and the Receiver 
Password is displayed in the right information bar. The user can Add, Edit, and Delete IP Receivers by either clicking on 
the corresponding button on the bar at the left, clicking on the button at the bottom of the screen, or right-clicking on the 
Receiver table. The Receiver T-Link Table can be accessed from here. 
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Receiver T-Link Table
The Receiver T-Link Table allows the user to access the IP Receivers currently stored in the table. The user can retrieve 
the T-Links that are currently communicating to the receiver, into a table by clicking on the Get and Merge IP Table 
button.  After retrieving the table from the receiver, existing T-Links in the current database are updated with the current 
Encryption key. 

To update changes to the receiver, click on Set IP Table. The user can add or delete T-Links from this table by clicking on 
the corresponding button at the bottom of the screen. The user can Save and Load T-Link Tables from  
clicking on the Save or Load button at the bottom of the screen.
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5   User Management
5.1   General

This is accessible to Supervisor, and Administrator access types. The User access type can only change their own 
password from here. It is be available by: 

• Clicking on the User Management tab at the top of the screen, 
• Clicking on the User Management bar on the left of the screen, 
• Clicking on the View menu bar at the top of the screen, and then selecting User Management.

The User Management table lists users that the user has access to view. You can add new users, delete users, or edit 
users by clicking on the corresponding button on the left, bottom, or right clicking on the table. 

Selecting Edit or Add a user displays the User Management form. Here you can enter the users Login Name, First and 
Last Name, user type, password and login expiry date.

Note: Supervisors can only create and edit Administrators and Users

Note: Administrators can only create and edit Users

When you edit an account, you will not be able to edit the login name. Administrators must create a new user to do so.
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5.2   Changing Passwords
DSC recommends that users change their password periodically to ensure security.  To change your login password, go 
to Change password in the File menu bar or select the Change Your Password  icon from the left side bar.  The 
following screen will be displayed

Enter your new password and then re-enter the password to confirm it as indicated below.  Click  OK to approve the new 
password.

Note: The password must be at least 8 characters long. 
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6   Logs
Logs are accessible to User, Administrator and Supervisor access levels. Only the Administrator level can edit, delete or 
export logs. Users can access Logs by:

• Clicking on the Logs tab at the top of the screen, 
• Clicking on the Logs bar on the left of the screen, 
• Selecting View > Logs from the menu bar

Logs list T-Link Console events  including Event Time, User, and Event . The Event Description box located in right 
Information bar contains additional information including; IP addresses and Account Name. This field can be edited by 
the Administrator. The Administrator level user can Delete one log, Delete All Logs, or Export all logs to an Excel 
spreadsheet. 

Note: A maximum of 65,535 logs can be exported to Excel®. 

Export logs periodically to avoid exceeding this limit. 

These options are available by clicking on the corresponding button on the left side bar, clicking on the button at the 
bottom of the screen, or right-clicking on the Logs table.
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7   T-Link Console Databases & Maintenance
All information required and used by the T-Link Console is stored in two databases, one for the user information and one 
containing the T-Link accounts information. 

The T-Link Console stores information about the T-Link Accounts in a database file. The user has the ability to create 
new database files to simplify management of a large number of accounts. Multiple database support also allows you to 
have duplicate account numbers, with different IP’s. 

User information is stored in a separate database. Passwords are encrypted using a dynamically generated key. The user 
type is not specifically encrypted, however a corresponding field is encrypted and checked against the user type to 
prevent tampering or changing the user type.

If the database becomes corrupted, the user can Compact and Repair the database. If the repair fails and the user has 
previously backed up the database, it can be restored. 

7.1   Maintenance

DSC recommends that Database maintenance be performed on a regular basis and when accounts are added and/or 
deleted. Database maintenance can be accessed by selecting Tool > Database Tools > Database Compact and Repair 
from the menu bar. The following screen will be displayed. Select the database you wish to compact and/or repair. 

Selecting Yes will perform the maintenance of the user database as well. If you did not add or delete any new users, this 
will not be necessary. If Yes is selected, the following confirmation will be displayed.

Note: All messages displayed by the T-Link Console close after 5 seconds.
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7.2   Backup
The backup feature allows the user to retrieve accounts information in the event of a database failure caused by any 
reasons such as power failure, hard drive failure etc. All events/activities that have occurred since the last back up are 
lost when a restore is performed.

Note: Backups should be done on a regular basis, and restore should be performed only when all other alternatives have 
been exhausted.

The backup function zips (compresses) the accounts database for retrieval at a later time. The backup can be accessed by 
selecting Tools > Database Tools on menu menu bar.

You can save the file with the current name provided by the Console (recommended), or change the file name to a name 
of your choice. The Restore function is available through the same menu. When selected, a confirmation message will be 
displayed:

By selecting Yes, all activities that occurred since the last back up will be deleted.
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Select the database you wish to restore.

7.3   T-Link Software Updates
Code Upload is performed in the Remote Programming section. When Code Upload is selected, the following screen 
will be displayed:

Note: The IP address entered here is used to connect to the T-Link. Refer to the T-Link Account section for more details.

The Default port used for code upload is 69. Ensure that this port is not blocked by any Ethernet devices such as routers, 
fire walls or gateways. When you have selected a file to upload, click on the Upload button. On completion of the 
upload, the T-Link Console Software will automatically disconnect from the T-Link.
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Glossary

10Base2 An older type of network Ethernet connection.  This is based on a loop of coaxial cable between 
all the computers that are connected together.

10Base5 The original IEEE 10 Mbps Ethernet standard which uses a thick coaxial cable.  Network nodes 
are attached via transceivers that tap into the cable and provide a line to a 15-pin plug in the 
adapter card known as the AUI interface.  Also called Thick Ethernet,ThickWire and ThickNet, 
10Base5 has a distance limit of 1,640 feet without repeaters.

10BaseT A current type of network Ethernet connection that operates over twisted pair cable.  This is more 
reliable and robust than the older 10Base2 connections.  This is usually arranged in a Star topol-
ogy.

100BaseT A newer version of 10BaseT connection that is yet again more robust and can handle even 
higher transfer speeds.

Account The portion of a signal which contains the information identifying the location or the owner of the 
alarm panel.  Also referred to as Account Number, Account Code or Account Digits.

Acknowl-
edgement  
(ACK)

A signal sent from the Receiver to the Panel indicating that data has been received.  A positive 
acknowledgement (ACK) means data was received without any detected errors. (see kiss-off).  A 
negative acknowledgement (NAK) means data was received, but there were detected errors.  An 
acknowledgement may be sent per packet or per alarm.

AHS Automatic Handshake Selection.  See ANI.

Alarm A message transmitted from the panel to the receiver containing account, event, zone, user or 
other information.  There may be one or more per call.  An alarm may be repeated in the same 
call (if not successfully delivered in a previous attempt).  An alarm will contain one or more pack-
ets.  Packets can contain rounds or different information.  Alarm transmission is initiated with a 
handshake and, if received correctly, acknowledged with a kiss-off.

ANI ANIAutomatic Number Identification.  Refers to the receiver feature whereby the line card may 
request the handshake to be used with a particular panel from the CPM3.  The CPM3 maintains a 
database of most recently used handshakes for all accounts connected to the receiver.  Hand-
shakes are stored along with the phone number of the associated alarm panel.

ARP Address Resolution Protocol.  A TCP/IP core protocol used to determine a host MAC address 
given only its corresponding IP address.  ARP is a required protocol in order for TCP/IP to func-
tion over Ethernet.  Defined in RFC 826.

ASCII America Standard Code for Informational Interchange.  A seven-bit alphanumeric code used 
extensively in data communications.  Parity is often added to the seven-bit code for error detec-
tion.

Automation The combination of software package and PC, which connects to the receiver to receive alarm 
events.  The automation can be connected either by direct serial connection (RS-232) or TCP/IP.

Automation 
Message

The alarm information delivered by a receiver in a specified protocol to a central station computer 
or network.  Also referred to as a Computer Message.

Backplane See BP3.

Bandwidth The amount of data that can be passed along a communications channel in a given period of 
time.

BC3 Battery Charger 3.  The PCB that is responsible for charging the battery on the System III 
receiver.

Bell 103 A standard for 110/300 bps communication.

Bell 212A A standard for 1200 bps communication.

Block A group of data that specifically makes up one of the elements of an alarm.  For example: 
Account block, event block, or alarm block.  One packet could contain multiple blocks.
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BP3 A motherboard style PCB which acts as the backbone for a single shelf of a System III receiver.  
The BP3 contains sockets to which up to 12 DRL3’s, 1 CPM3, 1 PSC3 and 2 DC/DC3’s can be 
connected.  Furthermore, 2 BP3’s may be connected together to form a 2 shelf configuration for 
the System III receiver.  The BP3 also contains connections for a parallel printer, a serial printer, 
and a serial automation COM port, as well as an Ethernet connection.  Also referred to as a Back-
plane.

Busy Out A state of a line card.  Under predefined criteria the line card will go off-hook so as to not process 
any new alarms.

Call The process of a receiver going off-hook, receiving one or more alarms and returning on-hook.

CAT5 Refers to a classification of Ethernet twisted pair cable (either shielded (STP) or unshielded 
(UTP)).  Classes CAT1, CAT2, CAT3, CAT4 and CAT6 also exist.  CAT5 is currently the most 
common variety, since it supports speeds of 100 Mbps, and therefore can be used in 10BaseT 
and 100BaseT installations.  The higher the number, the higher the transmission speed which is 
supported.

CE European approvals agency.

Centronics A parallel printer interface standard.  Also known as standard IEEE1284.  A Centronics interface 
is implemented on the CPM3 (through the backplane) to interface to the local parallel printer.

Checksum Additional data added to an Alarm indicating whether the contents have been received correctly.  
This is generally done by summing all the digits in the message (mod 256) and reporting this as 
the checksum.  Different methods of calculating a checksum may be specified in particular For-
mats or Protocols.

Console A PC application program which can connect to the receiver and provide diagnostic/programming 
abilities to the user.  For the System III, the console connects to the CPM3 via TCP/IP.

CPM3 Central Processing Module 3.  The CPM3 controls the overall operation of the System III receiver, 
which includes multiplexing alarm signals from the line cards and sending them to the appropriate 
outputs.

DC/DC3 The DC power supply of the System III receiver.  Can optionally be installed in a redundant con-
figuration on each shelf (slots are available for DC/DC3 A and DC/DC3 B).

DEOL Double end of line resistor.

DHCP Dynamic Host Configuration Protocol.  A protocol that provides a means to dynamically allocate 
IP addresses to computers on a local area network.  The system administrator assigns a range of 
IP addresses to DHCP and each client computer on the LAN has its TCP/IP software configured 
to request an IP address from the DHCP server.  The request and grant process uses a lease 
concept with a controllable time period.  Dynamic Host Configuration Protocol (DHCP) offers 
dynamic configuration of IP addresses and related information.  DHCP provides safe, reliable, 
and simple TCP/IP network configuration; prevents address conflicts; and helps conserve the use 
of IP addresses through a centralized address collection.

Dialer Another name for a panel.

DLS Downloading Software.  A DSC PC application used to configure panels.

DNIS Dialed Number Identification Service.  This is an arbitrary number assigned to represent the num-
ber that was dialed to reach the destination party.

DNS Domain Name System.  Name resolution software that lets users locate computers on a network 
or the Internet by domain name.  The DNS server maintains a database of domain names (host 
names) and their corresponding IP addresses.

DRL-IP A TCP/IP capable line card, which operates in conjunction with the DRL2E in order to provide 
TCP communications from the panel to the DRL2E/automation software.

DRL3-IP An Internet capable line card, which operates in conjunction with the System III in order to pro-
vide IP communications from the panel to the CPM3/automation software.

DRL3 Digital Receiver Line Card 3.

DSL Digital Subscriber Line (DSL, or Digital Subscriber Loop, xDSL - see below).  A family of digital 
telecommunications protocols designed to allow high speed data communication over the exist-
ing copper telephone lines between end-users and telephone companies.

DSP Digital Signal Processor.  A very powerful, calculus algorithm-based processor that can analyze 
and decode many different types of audio data.
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DTMF Dual Tone Multiple Frequency.  A method of dialing which utilizes 2 sets of 4 tones (frequencies) 
each.  Selecting one tone from each set will produce 16 distinct pairs.  These pairs are used to 
dial digits when dialing a telephone number.  Otherwise known as Touch Tone dialing.

Dynamic IP 
Address

The server assigns the IP address to the computer when it connects to the network.  The IP 
address is variable (see DHCP).

EOL End of line resistor.

Equivalent 
Line Number

An option in the receiver.  By default printer and computer messages will contain the line card 
number.  Sometimes it is necessary to make the printer and computer messages outputted with a 
different line card number, in this case this option can be used to overwrite the line card number 
in the printer and computer outputs of the receiver.

Ethernet A network protocol which encompasses the lowest logical layer of the network stack, immediately 
above the physical layer.  This protocol is governed by the IEEE and is outlined in the IEEE802.3 
specification.  Ethernet consists of several variations, including 10Base2, 10Base5, 10BaseT, 
100BaseT, and others.  10BaseT and 100BaseT are the most prevalent.

Event The specific type of Alarm being reported by the Panel.

Event Code A term used to describe a character or group of characters in an automation output.  This charac-
ter(s) is used to represent the Event that was reported by the panel.  

Example 1: SG automation reports an Alarm Event using an Event Code of “A”, Restore as 
“R”, or Trouble as “T”.  

Example 2: Sur-Gard automation reports using a SIA output for a Burglary Alarm an Event 
Code of “BA”.

Extranet An extension of an institution's intranet, especially over the World Wide Web, enabling communi-
cation between the institution and people it deals with, often by providing limited access to its 
intranet.

FCC Federal Communications Commission.

Firewall Any of a number of security schemes that prevent unauthorized users from gaining access to a 
computer network or that monitor transfers of information to and from the network.

Format The pre-established order of events and meanings of the various characters in an Alarm transmit-
ted from a Panel to a Receiver.

FTP File Transfer Protocol.  A protocol used to transfer files over a TCP/IP network.

Full-Duplex A mode of data transmission in which the data traffic can occur simultaneously in both directions.

G.726 An ITU standard for speech codecs that uses the ADPCM method to compress 64 Kbps PCM 
into 40, 32, 24 or 16 Kbps depending on available channel bandwidth.  G.726 generally replaces 
G.721 and G.723.

Gateway A device used to connect two different local subnets into one larger logical network.  A gateway 
has 2 IP addresses; one for each subnet it is connected to.  Essentially a gateway will decide 
where to send a packet so that it gets to its ultimate destination.  In addition, a gateway will often 
implement higher-level security functions, such as firewall protection, network address transla-
tion, etc.  This latter functionality is what distinguishes a gateway from a router.

Half-Duplex A mode of data transmission in which the data traffic can not occur simultaneously in both direc-
tions.

Handshake A signal sent by the Receiver to a Panel indicating that a connection has been established.  
These are either tones or modem data.

Heartbeat A periodic signal sent from the automation outputter tasks to the automation software to verify the 
presence of that output.  The period of this heartbeat is controlled via an option in the CPM3.  
Alternatively, the heartbeat refers to the signal sent between CPM3’s to verify the presence/
absence of each other.

Hook Flash The process of the receiver going temporarily off-hook, usually in an attempt to transfer the 
phone call.

Hot-
Swappable

Refers to the ability to add or remove particular cards to or from the system without removing 
power.  In the System III, the CPM3, DRL3, DC/DC3 and PSC3 are all fully hot-swappable.
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HTML Hypertext Markup Language.  The document format used on the World Wide Web.  Web pages 
are built with HTML tags (codes) embedded in the text.  HTML defines the page layout, fonts and 
graphic elements as well as the hypertext links to other documents on the Web.

HTTP Hypertext Transfer Protocol.  A higher level protocol within the TCP/IP suit of protocols which is 
responsible for implementing web browsers.  This is the protocol implemented by the CPM3 to 
enable the web interface to function.

HUB A hub is used to connect several computers together.  In a message handling service, a number 
of local computers might exchange messages solely with a hub computer.  The hub would be 
responsible for exchanging messages with other hubs and non-local computers.

IC Industry Canada.

ICMP Internet Control Messaging Protocol.  A protocol that is integrated at the IP level which essentially 
is designed to provide network diagnostic and error messages.  For the Scenix TCP/IP stack, a 
subset of the ICMP message set, namely the Echo Request and Echo Reply messages, are 
implemented.  Other ICMP messages cannot be handled by the T-Link II.  These 2 messages are 
the same 2 messages used by the ping utility.  For more information on ICMP, refer to RFC 792.

IEEE Institute for Electrical and Electronics Engineers.

IEEE 1284 See Centronics.

IEEE 802.3 See Ethernet.

Internal 
Trouble

A trouble condition which is generated inside a receiver, as opposed to being sent as an alarm 
from the panel.  Internal troubles are also sent to the printer and automation outputs.

Internet The biggest internet in the world.  This worldwide information highway comprises thousands of 
interconnected computer networks, and reaches millions of people in many different countries.  
The Internet was originally developed for the United States military, and then became used for 
government, academic and commercial research and communications.  The Internet is made up 
of large backbone networks (such as MILNET, NSFNET, and CREN), and smaller networks that 
link to them.  The U.S. National Science Foundation maintains a major part of the backbone 
(NSFNET).  The Internet functions as a gateway for electronic mail between various networks 
and online services.  The World Wide Web facility on the Internet makes possible almost instanta-
neous exchange of information by linking documents around the world.  Internet computers use 
the TCP/IP (Transmission Control Protocol/Internet Protocol).  There are over six million hosts on 
the Internet: mainframes, minicomputers or workstations that support the Internet Protocol.  The 
Internet is connected to computer networks worldwide that use various message formats and 
protocols; gateways convert these formats between networks so that the Internet functions as 
one big network.  UNIX utilities such as FTP, Archie, Telnet, Gopher and Veronica have been 
widely used to access the Internet.  The Internet sometimes appears to be amorphous and 
unregulated, but there are several administrative bodies: the Internet Architecture Board, which 
oversees technology and standards; the Internet Assigned Numbers Authority, which assigns 
numbers for ports and sockets, etc.; InterNIC, which assigns Internet addresses; the Internet 
Engineering and Planning Group, Internet Engineering Steering Group, and the Internet Society.  
Considered public (open access).

Intranet  A network based on TCP/IP protocols (an internet) belonging to an organization, usually a corpo-
ration, accessible only by the organization's members, employees, or others with authorization.  
A privately maintained computer network that can be accessed only by authorized persons, espe-
cially members or employees of the organization that owns it.  Considered private (limited 
access).

IP Internet Protocol. Pronounced as two separate letters.  IP specifies the format of packets, and the 
addressing scheme.  Most networks combine IP with a higher-level protocol called Transmission 
Control Protocol (TCP), which establishes a virtual connection between a destination and a 
source.  IP by itself is something like the postal system.  It allows you to address a package and 
drop it in the system, but there's no direct link between you and the recipient.  TCP/IP, on the 
other hand, establishes a connection between two devices so that they can send messages back 
and forth for a period of time.  Internet Protocol (IP) is the central, unifying protocol in the TCP/IP 
suite.  It provides the basic delivery mechanism for packets of data sent between all systems on 
an internet, regardless of whether the systems are in the same room or on opposite sides of the 
world.  All other protocols in the TCP/IP suite depend on IP to carry out the fundamental function 
of moving packets across the internet.
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IP Address An identifier for a computer or device on a TCP/IP network.  Networks using the TCP/IP protocol 
route messages based on the IP address of the destination.  The format of an IP address is a 32-
bit numeric address written as four numbers separated by periods.  Each number can be zero to 
255.

LAN Local Area Network.  Most LANs are confined to a single building or group of buildings.  However, 
one LAN can be connected to other LANs over any distance via telephone lines and radio waves.  
A system of LANs connected in this way is called a wide-area network (WAN).

Latency 1. The time it takes for a packet to cross a network connection, from sender to receiver.
2. The period of time that a frame is held by a network device before it is forwarded.  Two of the 

most important parameters of a communications channel are its latency, which should be low, 
and its bandwidth, which should be high.

Line An individual channel on a line card.  Equivalent to 1 telephone line.

Line Card A removable, hot-swappable card which contains a POTS line interface which controls 1 or more 
POTS lines.  For System III, each line card (DRL3) will interface to 1 line.

MAC Address A globally unique device address which is 6 bytes long, that identifies a device attached to an 
Ethernet network.  MAC stands for Media Access Control.  Assignment of MAC addresses are 
governed by the IEEE; any OEM company which manufactures Ethernet devices must apply for 
and purchase an OUI (organizationally unique identifier) which consists of a block of 16,777,216 
MAC addresses, all of which have the same first 3 bytes.  Subsequent allocation of addresses 
within that block are at the discretion of the purchaser.  Each Ethernet device produced must be 
programmed with a different MAC address in order to guarantee that each device will function 
correctly on the network.  For the System III, the MAC address is stored in serial EEPROM on the 
CPM3 board.  It is only programmable during manufacturing.

MLRF3 The metal rack which is used to enclose all other modules within a single shelf of the System III 
receiver.

MTU Maximum Transmission Unit.  The largest frame size that can be transmitted over a network.  
Messages longer than the MTU must be divided into smaller frames.  The MTU of Ethernet is 
1500 bytes (not including Ethernet frame bytes).

Multidrop A communication link in which a single channel is shared by several stations or nodes (DVAC is a 
Multidrop network).  Only one station may transmit at a time.  Multidrop is also referred to as mul-
tipoint.

NAT Network Address Translation.  A process often used in gateways to allow a local or wide area net-
work to connect to the internet.  Generally, it is a method of substituting reserved local IP 
addresses (which are not routable on the internet) with the address of the gateway, so that the 
packets can then be sent onto the internet.  In the opposite direction, the gateway would switch 
back the address to the local address so that the packet could then be received by the proper 
local network host.

Negative 
Acknowl-
edgement 
(NAK)

See Acknowledgement.

Network Two or more computer systems connected together.

N.C. Normally Closed.  The state of a zone input whereby the input is closed when there is no alarm 
condition present.

NIST National Institute of Standards & Technology.  The standards defining agency of the U.S. govern-
ment, formerly the National Bureau of Standards.

N.O. Normally Open.  The state of a zone input whereby the input is open when there is no alarm con-
dition present.

Off-Hook The process of connecting to the telephone line to answer an incoming Call or dial a remote 
device (Answering).

On-Hook The process of releasing the telephone line after completion of a call (Hanging-up).

Options A set of user-configurable parameters which controls the operation of a device.  In the System III, 
both the DRL3 and the CPM3 contain sets of options.   ADD STATIC / DYNAMIC OPTIONS 
description here

Packet A group of digits or characters of information in an Alarm.
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Packet
Switching

A type of network in which messages are divided up into discrete units called packets and routed 
independently of each other to their final destination.

Panel A device (the alarm system) at the protected premises used to transmit Alarms to the Receiver.

PBX/PABX Private Branch Exchange or Private Automatic Branch Exchange.  Terms used to describe pri-
vately owned or leased Telephone Switching Equipment.

PC-Link A serial connection present on many DSC panels which allows other devices such as the DLS or 
T-Link II to communicate with the panel.

Ping A standard network command which can be used to verify the presence of a device on a network, 
using the device IP address.  Ping is implemented as part of the ICMP Protocol and consists of 
the Echo Request and Echo Reply commands (poll and response respectively).
Ping of DeathA type of DoS attack.  The Internet Protocol (IP) defines the maximum size for a 
Ping packet.  However, some Ping programs can send packets that are larger than this size 
which can cause some systems to crash.

POTS Plain Old Telephone System.  An acronym used to describe a standard analog telephone net-
work, or alternatively a standard analog telephone line.

PPP Point To Point Protocol.  The communications protocol used to dial up the Internet over a serial 
link, such as a POTS or IDSN line.  Developed by the Internet Engineering Task Force in 1994, it 
superseded the SLIP protocol.  PPP establishes the session between the user's computer and 
the ISP using the Link Control Protocol (LCP), which also handles authentication (PAP, CHAP, 
etc.), compression and encryption.

PPPoE Point To Point Protocol over Ethernet.

Printer
Message

The alarm information delivered by a receiver to a central station printer.  This information is gen-
erally encapsulated in a descriptive English text message.

Protocol The pre-established order of events and meanings of the various characters in the information 
transmitted from a receiver to a monitoring computer.

PSC3 Power Supply Controller 3.  

PSTN Public Switched Telephone Network.  Analogous to POTS.

PSU3 Power Supply Unit 3.

RAM Random Access Memory.

RBUS The name given to the RS-485 bus which exists between the CPM3(s) and the line cards.

Receiver The equipment used to receive alarms sent from Panels.  Sur-Gard’s receivers are the SLR and 
the MLR.  Receiver is sometimes used interchangeably with Line card  as it is the line card that 
actually receives the alarm in the MLR.

Reporter IP A PC-based TCP/IP capable application developed by Sur-Gard intended to be used as a stan-
dalone receiver, with similar functionality to the embedded receiver/automation software.  This is 
one of the receiver types that the T-Link can connect to.

RFC Request For Comments.  A collection of freely available standards which define the protocols 
used in TCP/IP networking.

Ring One of the wires used on a phone line.  By convention this is red (See Tip).

ROM Read Only Memory.

Rounds Two or more packets of alarm information used for error checking.  If two packets (rounds) are 
identical the packet contains valid data.

Router A device in a network that handles message transfer between computers.
RRLLLThe part of the automation message which stores the receiver number and line card num-
ber.  The length of this field is variable and is controlled via options in both the line card and the 
CPM3.

RS-232 An asynchronous, point to point serial communications protocol.  Used to communicate between 
the DRL3 and a PC for the DRL3’s debug output.  Also used to communicate between the CPM3 
and the automation computer, and the CPM3 and a PC for the CPM3’s debug output.

RS-485 Multi-drop differential serial interface.  Used to communicate over the backplane between the 
CPM3’s and the line cards.

RTC Real Time Clock.
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SA System Administrator.  A DSC PC application used to configure panels that is a pared down ver-
sion of the DLS software.

Server One side of a two-sided TCP/IP socket connection.  The server is the one responsible for receiv-
ing the socket connection with the remote host (the client).  In general, a host which acts as a 
server can receive multiple client socket connection requests simultaneously.  The CPM3 acts as 
a server to both the console and the web interface.

SG Sur-Gard.  Also used to describe a particular type of automation output.

SIA Security Industry Association.  Sometimes referred to as the SIA format which is an example of 
FSK modulation.

SLIP Serial Line Interface Protocol.  A communications protocol for dial-up access to TCP/IP networks.  
It was commonly used to gain access to the Internet as well as to provide dial-up access between 
LANs.  SLIP transmits IP packets over any serial link (dial up or private lines).  SLIP has been 
mostly superseded by the Point-to-Point Protocol (PPP).

SMTP Simple Mail Transfer Protocol.  A standard TCP/IP protocol used to transfer email.

Socket 
Connection

A logical connection made between 2 hosts on a TCP/IP network.  A socket is uniquely defined 
by the combination of (IP address, port number) at both ends of the logical connection.

SRAM Static Random Access Memory.

STP Shielded Twisted Pair cable.  Refers to a type of Ethernet cable which is electromagnetically 
shielded to reduce interference effects.  See also UTP.

Subnet A portion of a network that shares a common address component.  On TCP/IP networks, subnets 
are defined as all devices whose IP addresses have the same prefix.  Dividing a network into 
subnets is useful for both security and performance reasons.  Subnet masks are 32-bit values 
that allow the recipient of IP packets to distinguish the network ID and host ID portions of the IP 
address.  Typically, subnet masks use the format 255.x.x.x.

System III Name given to a single entire receiver configuration, including rack, CPM3(s), line card(s), power 
supply, etc.

T-1 An AT&T term for a digital carrier facility used to transmit a DS1 formatted digital signal at 1.544 
megabits per second.  A T1 circuit requires two twisted pair lines, one for each direction.  Some 
newer equipment uses the two lines at half the T1 rate and in full-duplex mode; the sent and 
received signals are separated at each end by components collectively called a hybrid.  Although 
this technique requires more sophisticated equipment and lowers the line length, an advantage is 
that half the sent and half the received information is mixed on any one line, making low-tech 
wiretaps less of a threat.

TBD To Be Determined.

TCP/IP Transmission Control Protocol/Internet Protocol.  A standard network communications protocol.  
On the System III, TCP/IP is used to communicate between the console and the CPM3.  It is also 
used to connect the CPM3 to a TCP/IP Printer (resident on the console) and TCP/IP automation 
software (runs independent of the console).

TFTP Trivial File Transfer Protocol.  A version of the FTP protocol that has no directory or password 
capability.

Tip One of the wires used on a phone line.  By convention this is green (see Ring).

Trap To keep the panel on-line for programming purposes.

TTL Time To Live.  A set maximum amount of time a packet is allowed to propagate through the net-
work before it is discarded.

UDP User Datagram Protocol.  A TCP/IP protocol which allows for connectionless communications 
between two network hosts.  Retries are not handled and packet delivery is not guaranteed.  
Packets may also arrive out of sequence.

UL Underwriters Laboratories.  An independent, not-for-profit product safety testing and certification 
organization in the U.S.

ULC Underwriters Laboratories Canada.  See UL.

UTC Stands for “Universal Time Coordinated”, and is the standard time common to all places in the 
world.  It is also commonly referred to as GMT or World time.
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UTP Unshielded Twisted Pair cable.  Refers to a type of Ethernet cable which is not electromagneti-
cally shielded.  This type of cable is generally acceptable in most installations and is the more 
prevalent of the two cable classes, due to its lower cost.  See also STP.

VPN Virtual Private Network. The use of encryption in the lower protocol layers to provide a secure 
connection through an otherwise unsecure network, typically the Internet.  VPNs are generally 
cheaper than real private networks using private lines but rely on having the same encryption 
system at both ends.  The encryption may be performed by firewall software or possibly by rout-
ers.

WAN Wide Area Network.  A computer network that spans a relatively large geographical area.  Typi-
cally, a WAN consists of two or more local-area networks (LANs).  Computers connected to a 
wide-area network are often connected through public networks, such as the telephone system.  
They can also be connected through leased lines or satellites.

Zone The portion of an alarm which contains the information identifying the specific zone of the panel 
that has been violated.
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